Some phone calls to Canadian toll free numbers are not connecting

Minor incident Interactive Voice Response and SMS System
2025-03-10 14:10 CST · 19 hours, 55 minutes

Updates

Resolved

This issue appears to be resolved, if any further failures are observed please let us know

March 11, 2025 · 10:05 CST
Monitoring

Our infrastructure partner has let us know that the issue is resolved, we are continuing to monitor the situation, please let us know if any further issues are encountered

March 11, 2025 · 08:05 CST
Issue

We are observing call failures to a subset of our Toll Free numbers from Canadian Network Subscribers.

We are continuing to monitor this incident and will post an update when we get more information

March 10, 2025 · 14:10 CST

← Back