We are investigating an outage of one of our cloud service providers

Major incident Cloud Provider
2025-09-24 18:02 CST · 15 hours, 7 minutes

Updates

Resolved

This issue has been fully resolved.

September 25, 2025 · 09:09 CST
Monitoring

Our cloud services are now recovering. We are continuing to monitor the situation. Customers may experience delays in notifications and with shift processing while the backlog is processed.

September 24, 2025 · 19:00 CST
Issue

We have detected issues and we are currently investigating.

Services such as email, SMS, and phone notifications may be unavailable while this incident is ongoing.

September 24, 2025 · 18:02 CST

← Back